Deposit on Morpho Blue through Fireblocks

Hello folks,

We have been reported issues from different Morpho users, where they were trying to deposit assets into Morpho Blue thanks to wallet connect and Fireblocks.

I can’t connect myself from any browser (Chrome, Safari nor Brave),

The flow is as follows:
Whenever I try to click on FireBlocks on the wallet connect button from, it redirect me to the auth page. I put the google sign in, that redirect me to the 2FA process.
Whenever I put the right code, it is just indicating:
“Failed to load resource: the server responded with a status of 403 (),

And if I put a wrong code on purpose, it is indicating that the code is wrong → so this is not a credential trouble.

Thing is I am trying to connecting on Ethereum Mainnet, not to the fireblocks sandbox but to the fireblock button from wallet connect.

Is it normal, and I missed something? Is there anything we can do?
I tried with different emails, never got connected

Thanks a lot for your time, hope we will solve this asap

Hey @tom as discussed over TG the issues that you’ve experienced are because you’ve tried to connect a MAINNET only dApp to a Sandbox workspace which supports only TESTNET.