Problem with creating new API user in Sandbox

I’m having a problem with creating new API user in Sandbox.
According to sandbox quickstart(Developer Sandbox Quickstart Guide), I can choose a ‘Non-signing Admin’ with ‘Automatic CSR’ but I can’t see this in my workspace, in mine it requires CSR file and says that- Owner approval is required. I’ll attach screenshots.
I also tried the custom CSR, with instructions from here- Quickstart Guide, but failed at step 1, after copying the command line, it can’t find the file, Screenshot attached.
Could you please help me?

Hi Abigail,
the command is not finding the file but to generate the key pair
You should either remove the part ‘/O=<your_organization>’ or enter your organization name.
Please note there is a limit of 5 API users per workspace.

Please follow the guide below on how to create API users.

Hey Abigail, can you please specify the name of the workspace you were facing this issue in?

Hi @mnamakwala, thank you for your reply!
I think my workspace name is- PS Candidate- Abigail D. (that’s what it says on the top right corner).
I tried the command without organization name part, but it asks for a challenge password that I don’t have. I also tried following the guide but I couldn’t figure how to approve the new API user as I’m the owner. How would I go about it? thanks

Hi Abigail,
I see that your workspace is not a sandbox but a testnet workspace. I do not see any sandbox workspaces with that name.
You created two ADMIN API users in your workspace, and they are in a ready state. You approved the addition of these users and their keys during the pairing stage of cosigners on your Fireblocks mobile app. I hope this clears it up. Once the user is created you will receive those requests on your mobile app.