Testing sandbox with Postman collection no results

I have got access to Sandbox. I have created api user and downloaded the secret.

I have setup the postman collection Boiler plate Fireblocks Environment as suggested .

When I run any GET request (e.g ‘Fireblocks Console’) I get 200 response but I don’t get any response body with results. Instead I get a html which is nothing but Fireblocks Logo.

Am I missing any thing in testing Fireblocks Postman scripts collection?


Hey! Can you please make sure that the baseUrl param is set with the following value?


Thank you. Now I am getting 401 - unauthoriszed , JWT is missing.

Hey @seshalkimi seems that the env params weren’t set as expected.

Can you please verify that you have set all the env params as described in here:

Hi @SlavaSereb

I followed the details as per the documentation and set environment variables.

Please do not Share your API keys and/or Private keys - Per our Guidelines (I removed the screenshot - Sagar (Forum Admin)), You can mask them and leave either first 4 or last 4 digits of the keys if absolutely needed

Please see image attached.


Hi @seshalkimi – it looks like this API user is disabled. Can you please retry the above with an enabled API user? You can log into the console and navigate to the users page to double-check the state of users on your workspace.

Hi SlavaSereb,

I have created a new api user now, “seshapi” and used those new api key and secret. I am still getting { “message”: “Unauthorized: JWT is missing”, “code”: -3} error for https://sandbox-api.fireblocks.io/v1

Hi @seshalkimi,

Are you able to double check that the Postman collection has had the environment variables correctly entered?

If so and you are still facing issues, can you post screenshots of:

  1. the collection’s pre-request script
  2. the collection variables
  3. the selected/active environment
  4. the environment variables, masking both the X-API-KEY and secret

Hi @danielk

I am unable to post all screen shots at once as i get message “new use can post 1 image”. I sending one at a time.

Pre-request script

Collection variables


Environment variables

@seshalkimi: As per the instructions earlier in the other thread, and as per point #3 under the section “Update environment variables” in the documentation, you have to check your baseUrl setting - the current value must be https://sandbox-api.fireblocks.io.

Hi @danielk
In this same thread @SlavaSereb suggested to use base url as [https://sandbox-api.fireblocks.io/v1.
I have now tested https://sandbox-api.fireblocks.io and I am still getting same error ==> “{ “message”: “Unauthorized: JWT is missing”, “code”: -3}”.

Hi @seshalkimi, I see you have both the FirebocksApiKey variables enabled in both the Postman Environment and the Fireblocks API Collection.

Please ensure you deactivate or remove one (from either the environment or the collection).


@seshalkimi : Forgot to add: the same duplication is seen for baseURL - please ensure only one is available and set correctly. This will eliminate chances of incorrect scoped variables being used.

FWIW: the environment variables takes precedence over collection variables. Using variables | Postman Learning Center

Hi @danielk

I removed duplication.
When I run with base url set as - https://sandbox-api.fireblocks.io as you suggested I am getting 404 (not found).
When I run with base url set as https://sandbox-api.fireblocks.io/v1 then I am getting - { “message”: “Unauthorized: JWT is missing”, “code”: -3}


Hi @danielk

It is now working. Tested with couple of endpoints and I see successful results.

Thank you all for your help.